$re = '/^(?!.*\h\S)[\da-zA-Z\h]{12}$/m';
$str = 'abcdef12345
abcdef1234
abcdef123456
abcdef 23456
abcdef12345
abcdef12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);