package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){"old.+}}`)
var str = `INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={"sourceId":"Data","sourceType":"info","timestamps":{"original":"1543849385073","uiPublish":"1543849385073"},"correlationId":"1543849385073_2272_38","object":{"old":{"mystate":"complete","state":"item"},"new":{"mystate":"complete","state":"myitem"}},"timestamp":"1543849385073"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}