import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\"old.+\\}\\}";
final String string = "INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={\"sourceId\":\"Data\",\"sourceType\":\"info\",\"timestamps\":{\"original\":\"1543849385073\",\"uiPublish\":\"1543849385073\"},\"correlationId\":\"1543849385073_2272_38\",\"object\":{\"old\":{\"mystate\":\"complete\",\"state\":\"item\"},\"new\":{\"mystate\":\"complete\",\"state\":\"myitem\"}},\"timestamp\":\"1543849385073\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}