use strict;
my $str = 'INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={"sourceId":"Data","sourceType":"info","timestamps":{"original":"1543849385073","uiPublish":"1543849385073"},"correlationId":"1543849385073_2272_38","object":{"old":{"mystate":"complete","state":"item"},"new":{"mystate":"complete","state":"myitem"}},"timestamp":"1543849385073"}';
my $regex = qr/{"old.+}}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}