// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m){"old.+}}"#).unwrap();
let string = "INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={\"sourceId\":\"Data\",\"sourceType\":\"info\",\"timestamps\":{\"original\":\"1543849385073\",\"uiPublish\":\"1543849385073\"},\"correlationId\":\"1543849385073_2272_38\",\"object\":{\"old\":{\"mystate\":\"complete\",\"state\":\"item\"},\"new\":{\"mystate\":\"complete\",\"state\":\"myitem\"}},\"timestamp\":\"1543849385073\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}