#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S(?:[^.]+|\.\S)+\."
Local $sString = "Recent studies have described a pattern associated with specific object (e.g., face-related and building-related) in human occipito-temporal cortex. However, it is as yet unclear to what extent this selectivity is due to differences in the statistics of local object features present in the different object categories, and to what extent it reflects holistic grouping processes operating across the entire object image. To resolve this question it is essential to use images in which identical sets of local features elicit the perception of different object categories. The classic Rubin vase–face illusion provides an excellent experimental set to test this question. In the illusion, the same local contours lead to the perception of different objects (vase or face). Here we employed a modified Rubin vase–face illusion to explore to what extent the activation in face-related regions is attributable to the presence of local face features, or is due to a more holistic grouping process that involves the entire face figure. Biasing cues (gratings and color) were used to control the perceptual state of the observer. We found enhanced activation in face-related regions during the ‘face profile’ perceptual state compared to the ‘vase’ perceptual state. Control images ruled out the involvement of the biasing cues in the effect. Thus, object-selective activation in human face-related regions entails global grouping processes that go beyond the local processing of stimulus features." & @CRLF & _
"Neural analysis of the visual scene in early visual areas is inherently local. The receptive fields of neurons in these areas are relatively small and sensitive to local edges and contours. Yet visual perception of objects is global and unified. This transformation requires grouping processes by which local features have to be ‘‘assigned’’ to a particular figure (e.g., Ullman, 1996; Marr, 1982). Surprisingly little physiological evidence has been obtained that directly explores the neural correlates of such perceptual phenomena (but see recent single-unit recording works by Zhou, Friedman, & von Der Heydt, 2000; Lee, Mumford, Romero, & Lamme, 1998; Zipser, Lamme & Schiller, 1996; Lamme, 1995)." & @CRLF & _
"Recently, a substantial number of neuroimaging studies have found that human lateral occipital and occipito-temporal cortex is sensitive to images of objects compared to a variety of textures and noise patterns (Kourtzi & Kanwisher, 2000a; Grill-Spector et al., 1999; Ishai, Ungerleider, Martin, Schouten, & Haxby, 1999; Malach et al., 1995). Furthermore, subdivisions of occipito-temporal cortex have been reported to show segregation according to specific object categories. Prominent examples are areas selective tive for faces (Haxby, Hoffman, & Gobbini, 2000; Tong, Nakayama, Moscovitch, Weinrib, & Kanwisher, 2000; Halgren et al., 1999; Kanwisher, Chun, McDermott, & Ledden, 1996) and buildings (Aguirre, Zarahn, & D’Esposito, 1998; Epstein & Kanwisher, 1998) as well as other object categories (Ishai et al., 1999). It is generally assumed that such category-specific organization necessarily implies a holistic representation that goes beyond local features. Indeed, high-order object representations do show remarkably abstract characteristics such as substantial size and position invariance (Grill-Spector et al., 1999), and invariance to the visual cues used to define objects (Gilaie Dotan, Ullman, Kushnir, Steinberg, & Malach, 2000; Kourtzi & Kanwisher, 2000a; Grill-Spector, Kushnir, Edelman, Itzchak, & Malach, 1998)." & @CRLF & _
"Nevertheless, selective activation to one set of objects relative to another can still be explained by differences in the distribution of local object elements or features. To appreciate this point, consider a small aperture that samples local parts of an object, such as a tumbler or a face (Figure 1A and B). It is rather straightforward to see that although the sampling from the two images is strictly local, the aggregate distributions of local object features that can be obtained from the two object categories are substantially different and thus could provide the basis for the observed object selectivity."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")