#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?"
Local $sString = "https://www.youtube.com/watch?v=a54d65asd45a6sd4" & @CRLF & _
"http://www.youtube.com/watch?v=aldkjalksdj1203" & @CRLF & _
"www.youtube.com/watch?v=" & @CRLF & _
"youtube.com/watch?v=" & @CRLF & _
"https://youtu.be/asdas123123" & @CRLF & _
"http://youtu.be/asdas123123" & @CRLF & _
"youtu.be/lakdjklj123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")