using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!£)\b(\d+)\b";
string substitution = @"£$1";
string input = @"1-10
10-20-30
500-600-800
£500";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}