use strict;
my $str = '1-10
10-20-30
500-600-800
£500';
my $regex = qr/(?<!£)\b(\d+)\b/p;
my $subst = '£$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";