$re = '/(?<!£)\b(\d+)\b/';
$str = '1-10
10-20-30
500-600-800
£500';
$subst = "£$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;