using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'int'[1-2]?[1-9]|3[01])((,\g'int')|(-\g'int'(?=$|,)))*$";
string input = @"2-2,1
1-5,5,15-29
1-1-1-1
2,5,7-20
2,3-6,3
1-24,5-6,2-9
15,25,3
412,28,1-31,15
1-5,5,15-32
1-5,5,45-31";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}