// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)^(?:(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])$").unwrap();
  let string = "0.0.0.0
1.1.1.1
9.9.9.9
10.10.10.10
99.99.99.99
100.100.100.100
199.199.199.199
200.200.200.200
255.255.255.255
256.256.256.256
1.1.1.1.1
foo.bar.baz.qux";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}