#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=(([^"]*"){2})*[^"]*$)Dogs"
Local $sString = "Dogs are scary but my mom told me that "Dogs are cute""
Local $sSubst = "Cats"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)