using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([0-9]+\s?)+)(\$|EUR)";
string input = @"player number 8 have a nice day. the price is 1 000 $ or you have to pay 2000$. 1000$ and 1000EUR";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}