package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([0-9]+\s?)+)(\$|EUR)`)
var str = `player number 8 have a nice day. the price is 1 000 $ or you have to pay 2000$. 1000$ and 1000EUR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}