$re = '/(([0-9]+\s?)+)(\$|EUR)/';
$str = 'player number 8 have a nice day. the price is 1 000 $ or you have to pay 2000$. 1000$ and 1000EUR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);