$re = '/binary_function\(\[([^][\s,]+),([^][\s,]+)]\)/m';
$str = 'binary_function([x,y])
binary_function([x1,y1])';
$subst = "\U$1$2\E";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;