$re = '/[0-9]*(KG|ML)[0-9]*/';
$str = '124521test45125 100KG10 fdfdfdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);