#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$"
Local $sString = "1234 AB"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)