const regex = new RegExp('\\[([^\\]]+)]"?$', 'gm')
const str = `NO MATCHES:
[q:Sacks and Snow: The Snow Child's Name] has run out of time. It asks to see you.
"My sleep is riddled with dreams, [q:Addressed As]. Dreams of bells and candles!"
The pirates must learn that [q:Pigmote Isle: Mastery] will fight back.
[CHANGE_TERRAIN],EmpireofHands/airbase_half,EmpireofHands/airbase_burnt
<b>MAYBE'S DAUGHTER</b>: Hello, Auntie.\\r\\n<br/>\\r\\n<b>PARABOLAN PANTHER<b/>: [Silence.]\\r\\n<br/>\\r\\n<b>MAYBE'S DAUGHTER</b>: Fair point. Let's keep it to ourselves for now.\\r\\n
O[xxxxx] THRR [xxxxx] N KUTHE TH[xxxxxx].
SHOULD MATCH:
"[q:Addressed As]. I know the way. Let me show you."\\n[The Exile is a First Officer.]
(just the last part!)
"Herein are recorded certain details of a Voyage through [xxxxx] in the company of [xxxxxx], on [xxxxxx]...." [Use this to increase your Pages]
(how? it ends with quotes!)
"P drowns in PELIGIN, the colour of the deepest zee. [Someone has scrawled in the margin: BEYOND THE GATE THERE IS A SEA MORE SUNLESS]"
(trailing spaces)
Decide later. [If you just want to get out to zee immediately, choose this. Opportunities to revisit your past will arrive later.]
Really it's just him you want to understand. [This will certainly get you kicked off the island.]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}