#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:(?!cat).)*cat(?:(?!cat).)*)cat"
Local $sString = "cat goose mouse horse pig cat cow"
Local $sSubst = "\1Bull "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)