// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^20(((([248][048])|([13579][26]))\/(((0[13578]|1[02])\/([0-2][0-9]|3[01]))|((0[469]|11)\/([0-2][0-9]|30))|(02\/([0-2][0-9]))))|((([248][1-35-79])|([13579][013-57-9]))\/(((0[13578]|1[02])\/([0-2][0-9]|3[01]))|((0[469]|11)\/([0-2][0-9]|30))|(02\/(((0|1)[0-9])|(2[0-8]))))))$").unwrap();
let string = "2015/02/28";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}