use strict;
my $str = 'copy table values from \'a.dat\';';
my $regex = qr/(?<=\bcopy\b)[\s\S]*?(?=\s*\bfrom\b)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";