re = /(?<=\bcopy\b)[\s\S]*?(?=\s*\bfrom\b)/m
str = 'copy table values from \'a.dat\';'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result