#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"id":\s*"\K[^"]*"
Local $sString = " "id": "EFM"," & @CRLF & _
" "type": "Casual"," & @CRLF & _
" "hasBeenAssigned": false," & @CRLF & _
" "hasRandomAssigned": false" & @CRLF & _
" },"
Local $sSubst = "replaced"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)