using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""id"":\s*""\K[^""]*";
string substitution = @"replaced";
string input = @" ""id"": ""EFM"",
""type"": ""Casual"",
""hasBeenAssigned"": false,
""hasRandomAssigned"": false
},";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}