re = /"id":\s*"\K[^"]*/m
str = ' "id": "EFM",
"type": "Casual",
"hasBeenAssigned": false,
"hasRandomAssigned": false
},'
subst = 'replaced'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result