#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[^/])\n"
Local $sString = "IMP007 - Verwijzende code onbekend[7]" & @CRLF & _
"IMP013 - Ziekenhuis registratienr dubbel[13]" & @CRLF & _
"IMP027 - De verrichting is niet gerelateerd aan de batch type[27]"
Local $sSubst = ", "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)