using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^/])\n";
string substitution = @", ";
string input = @"IMP007 - Verwijzende code onbekend[7]
IMP013 - Ziekenhuis registratienr dubbel[13]
IMP027 - De verrichting is niet gerelateerd aan de batch type[27]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}