re = /(?<=[^\/])\n/m
str = 'IMP007 - Verwijzende code onbekend[7]
IMP013 - Ziekenhuis registratienr dubbel[13]
IMP027 - De verrichting is niet gerelateerd aan de batch type[27]'
subst = ', '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result