#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\s)((?:[^h ]|h(?!elp))+\/pdf\/\S*)(?:$|\s)"
Local $sString = "Shouldn't match: " & @CRLF & _
" /dealer/help/us/en/pdf/simple.pdf Should match: " & @CRLF & _
"/dealer/us/en/pdf/simple.pdf Shouldn't match: " & @CRLF & _
" /dealer/help/us/en/pdf/simple.pdf Should match: " & @CRLF & _
"/dealer/us/en/pdf/simple.pdf Shouldn't match: " & @CRLF & _
" /dealer/help/us/en/pdf/simple.pdf Should match: " & @CRLF & _
"/dealer/us/en/pdf/simple.pdf Shouldn't match: " & @CRLF & _
" /dealer/help/us/en/pdf/simple.pdf Should match: " & @CRLF & _
"http://myhel.com/dealer/us/en/pdf/simple.pdf Shouldn't match: " & @CRLF & _
" /dealer/help/us/en/pdf/simple.pdf Should match: " & @CRLF & _
"/dealer/us/en/pdf/simple.pdf Shouldn't match: " & @CRLF & _
" /dealer/help/us/en/pdf/simple.pdf Should match: " & @CRLF & _
"/dealer/us/en/pdf/simple.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")