use strict;
my $str = 'Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
http://myhel.com/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf';
my $regex = qr/(?:^|\s)((?:[^h ]|h(?!elp))+\/pdf\/\S*)(?:$|\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}