$re = '/(https?:\/\/www\.google\.(?:(?:com)|(?:co\.in)).*#q=.+)/im';
$str = 'https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ#q=sss&safe=active
https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);