import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=\\b\\d{3}\\b)0?1?2?3?4?5?6?7?8?9?(?<=\\d{3}))";
final String string = "012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089\n"
+ "911\n"
+ "900\n"
+ "891\n\n"
+ "000 010 011 987 876 765 654 543 432 321 210";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}