const regex = /^(\d{4})[\/\-](0?[1-9]|1[012])[\/\-](0?[1-9]|[12][0-9]|3[01])$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4})[\\\/\\-](0?[1-9]|1[012])[\\\/\\-](0?[1-9]|[12][0-9]|3[01])$', '')
const str = `2015-03-12`;
const subst = `$3-$2-$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);