use strict;
my $str = '2015-03-12';
my $regex = qr/^(\d{4})[\/\-](0?[1-9]|1[012])[\/\-](0?[1-9]|[12][0-9]|3[01])$/p;
my $subst = '$3-$2-$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";