$re = '/^(\d{4})[\/\-](0?[1-9]|1[012])[\/\-](0?[1-9]|[12][0-9]|3[01])$/';
$str = '2015-03-12';
$subst = "$3-$2-$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;