$re = '/[^a-zA-Za-åa-ö-w-я 0-9/@%!"#?¨\'_.,]/i';
$str = 'allows email, text and number in latin and cyrillic alaphbet.
but prevents special charcters.
Hello, :()*&^<>
example@mail.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;