// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?i)[^a-zA-Za-åa-ö-w-я 0-9/@%!"#?¨'_.,]"##).unwrap();
let string = "allows email, text and number in latin and cyrillic alaphbet.
but prevents special charcters.
Hello, :()*&^<>
example@mail.com";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}