import Foundation
let pattern = ##"[^a-zA-Za-åa-ö-w-я 0-9/@%!"#?¨'_.,]"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
allows email, text and number in latin and cyrillic alaphbet.
but prevents special charcters.
Hello, :()*&^<>
example@mail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)