package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"([23]{1,7})"`)
var str = `"3"sca"""co"1"str"0"ctor""r"3"t"0"r"1""locat"5"o"133""0"27""754a49b393c2a0"33"b97"332"cb7"3"c3c07"2""co"1"str"0"ct"233223322"or""r"3"t"0"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}