import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[(img|\\w{4,})\\][\\s\\S]*?\\[\\/\\2\\])(\\n?)|([\\s\\S]+?)(\\n?)(?=$|\\[(?:img|\\w{4,})\\])";
final String string = "Cum haec taliaque sollicitas eius aures everberarent expositas semper eius modi\n"
+ "rumoribus et patentes.\n"
+ "[image]https://foo.com/fighters.png[/image]\n"
+ "Denique Antiochensis ordinis vertices sub uno elogio iussit occidi ideo efferatus,\n"
+ "quod ei celebrari vilitatem intempestivam urgenti, cum inpenderet inopia\n"
+ "[image]https://foo.com/fighters1.png[/image]\n"
+ "[image]https://foo.com/fighters2.png[/image]\n"
+ "Utque proeliorum periti rectores [i]primo catervas[/i] densas opponunt et fortes,\n"
+ "deinde leves armaturas, post iaculatores ultimasque subsidiales acies, si fors\n"
+ "adegerit";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}