const regex = /\[(\d+)\]$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\d+)\\]$', '')
const str = `attachments[23543][non-users][33]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);