$re = '/\[(\d+)\]$/';
$str = 'attachments[23543][non-users][33]';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;