import re
regex = re.compile(r"\[(\d+)\]$")
test_str = "attachments[23543][non-users][33]"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)