#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{3}-\d{3}-\d{4}$"
Local $sString = "616-555-1212" & @CRLF & _
"555-1212" & @CRLF & _
"6165551212" & @CRLF & _
"asdf" & @CRLF & _
"1" & @CRLF & _
"800-111-2222" & @CRLF & _
"800-111-2222d" & @CRLF & _
"800-11a-2222" & @CRLF & _
"." & @CRLF & _
"112" & @CRLF & _
"-" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")