using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?>\/\*(?>(?:(?>[^*]+)|\*(?!\/))*)\*\/)";
string substitution = @"";
string input = @"/* 34:
*
*
*
*/
/*
* JD-Core Version: 0.7.0.1
*/
test
test
test
/* another comment */
test
test
test
/*
another comment with
new
lines
*/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}