# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(?>\/\*(?>(?:(?>[^*]+)|\*(?!\/))*)\*\/)"
test_str = ("/* 34: \n"
"*\n"
"*\n"
"*\n"
" */\n\n\n"
"/*\n\n"
" * JD-Core Version: 0.7.0.1\n\n"
"*/\n\n"
"test\n"
"test\n"
"test\n\n"
"/* another comment */\n\n"
"test\n"
"test\n"
"test\n\n"
"/*\n"
"another comment with\n"
"new\n"
"lines\n"
"*/")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.