package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<bean:write[^\/]*\/>`)
var str = `<input name="id" type="radio" bgcolor="<bean:write name='color'/>" value="<bean:write name='nameProp' property='nameVal'/>" <logic:equal name="checkedStatus" value="0">checked</logic:equal>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}