import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\n(([^\"]*\"){2})*[^\"]*$)\\n";
final String string = "column1rowA \"column2rowA\" column3rowA column4rowA\n"
+ "column1rowB column2rowB \"column3rowB\n"
+ "3Bcont\n"
+ "3Bcont\n"
+ "3Bcont\n\n"
+ "\" column4rowB\n"
+ "column1rowC column2rowC column4rowC\n"
+ "column1rowD column2rowD \"column3rowD\n"
+ "3Dcont\" column4rowD";
final String subst = "<br>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}